Categories
Apple

How would an average user handle this?

I’ve been using an iMac as my primary home computer for the last five years. Nice system, both as a desktop and as a server for the rest of the apartment, with a string of FireWire drives hanging off the back. It came with 4GB RAM, and in 2012 I added an extra 8GB so that I could run VirtualBox VMs. However in recent months it’s started to misbehave; about 10% of the time the display won’t come back from screen saver or sleep, and I have to restart via Cmd-Ctrl-Power. So I decided to replace it with a new iMac. Nothing too extravagant: a 21.5″ Retina iMac with Core i5, 16GB RAM, 1TB Fusion disk. (I looked at the 27″ model with a discrete GPU, but I couldn’t justify the expense. I’m not really a graphics junky. More practically, the 27″ wouldn’t fit under my over-desk cupboards.) I also ordered a FireWire-to-Thunderbolt adapter, hoping that my existing storage setup would just work.
The new iMac arrived yesterday, and I had a decision: clean install, or transfer from the old system? With the previous iMac, I’d done a transfer from my Mac Mini, so I knew that there was quite a bit of cruft in there. On the other hand, my Mail, iTunes and backup (Time Machine and Backblaze) configurations are complicated, and I was inclined to let the Migration tool take care of them. So I booted up the new system, hooked them together with an Ethernet cable, and let it rip. Six hours later, it was done. I plugged in my FireWire chain, using the new adapter, and everything just worked.
Sort of.
I spent a couple of hours testing and tweaking stuff, amused to see which apps required re-authentication and which ones treated this as a reincarnation of an already-trusted system. And then I remembered that I’d forgotten one cardinal rule: I hadn’t checked for software updates. So I did… and the OS X 10.11.1 update wouldn’t work. It just hung. Perhaps it was a “first boot” issue; I’ve often noticed that things in OS X don’t work quite right after an update, and a reboot usually fixes them. So I chose restart.
Black screen. “Bong” sound. White Apple logo. Then "kernel panic" in the top left corner.
Tried again. Same result.
I contemplated the time required to do a full reinstall of OS X. I wondered about Genius Bar appointments. And then I decided to reboot in Safe Mode (holding down shift right after the “Bong”). That worked, though the system was glacially slow.
So I grabbed my rMBP (what would I have done with only one computer?) and started searching for kernel extensions that might be causing the problem. Eventually I found this piece about VirtualBox-related panics. I opened a terminal, deleted the offending files, and rebooted. The panic was gone – and, equally important, the 10.11.1 update installed correctly. Later today I’ll try a clean installation of VirtualBox to see if it’s OK. (I use a VirtualBox VM to cache all of my context for open source work, including keys and git scripts.)
Whew.
(And the Retina 4K display on the new iMac is just gorgeous.)